mk808 not working help | MK 808 | Android Mini Pc Forums

Share

Please consider registering
guest

Log In Register Members

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Topic RSS
mk808 not working help
November 30, 2012
4:43 pm
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

Hi all
I am new here and unfortunately join with a problem.
I first heard of mini pcs a few weeks ago and was instantly intrigued
I ordered a MK808 from amazon and it came yesterday
However its not working :(

I plug it in and the google tv logo and android logo appear then nothing
I just get a message saying no signal
I tried it on two TVs and with different power supplies but no luck
I have ordered a new mini HDMI cable just in case that the problem and have contacted the seller

Is there anything particular that could be causing this or I can do to try and fix it or is it just fucked

Share
December 2, 2012
9:44 am
audiobore

Member
Forum Posts: 35
Member Since:
November 21, 2012
Offline

Don't bin it yet! I had the very same issues last week. flashed the firmware as per instructions in the forum, still no joy. changed the power supply to a 2000ma 5v dual USB (Uniross) and it solved everything. Great wee device when u finally get there. Tons of potential.

Not a tv compatibility issue if u see the load screen.

Good luck

Share
December 2, 2012
5:56 pm
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

Thanks
Do you think it was just a plug problem or was flashing needed aswell
I dont want to flash it til I hear from the seller and am worried about doing it in general

As I said I tried different plugs but no idea what kind of plugs they are other than general USB chargers

I hope to get it working before too long

PS could you post a link to the plug you bought I googled it and am getting different results

Thanks

Share
December 3, 2012
5:13 am
audiobore

Member
Forum Posts: 35
Member Since:
November 21, 2012
Offline

Hi, it is hard for me to tell but I suspect it was the pwr supply that made the difference. I understand your caution about flashing the device. I was in the same situation and asked the vendor if I should do this to which they said no. When the vendor conceded that my current setup would not work and that the unit must be faulty they agreed to a refund or send another unit (no need to return the faulty one to China!). Unit number two is on the way so unit number is now an MK808 laboratory ;) I would definitely not risk losing a refund or exchange option by not following their instructions.

Incidentally, the Chinese vendor was very responsive despite the language barrier and some technical deficiencies.

If you do end up in the position where flashing the device is no longer a risk i can vouch for the instructions on the site (usual caveats apply). It worked a treat for me.

This is the UK power supply i bought......

http://www.amazon.co.uk/Uniros.....038;sr=8-1

Definitely get in touch with your vendor, they may surprise you.

Good luck

Share
December 3, 2012
6:43 am
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

thanks for your reply
I havent heard back from the seller yet
I will order the plug today and hope for the best

So does your device not work at all at the moment?

I read else were you can partially flash your device by loading the files via the SD slot and then go through a setup

I cant understand why you would sell a product without the right power source or sodtware

Share
December 3, 2012
9:30 am
mk007

New Member
Forum Posts: 1
Member Since:
December 3, 2012
Offline

@espressox: Sir, I am probably as new as you to using MK808 (just 4 days since I got hold of mine). I had faced exactly the same problem that you had mentioned. After having tried all different options for almost 3-4 hours, I was about to give up and then I tried powering the stick directly from the TV's usb and that did the trick...

Initially, it would just stall after the android screen but now it boots beyond :) . Hope this is of some help.

mk007
ps: I read somewhere that it is best to use a 5v, 2A and not a 5v, 1a adapter...

Share
December 3, 2012
11:59 am
audiobore

Member
Forum Posts: 35
Member Since:
November 21, 2012
Offline

Espressox, yeah, the device s working a treat now. I am typing this response on it. As MK007 states the 2A supply would seem to be essential. I think the Chinese electronics industry is a bit more cut-throat so gettting the product into the field is more important than stringent ship support criteria. The upside of this is that we are able to get a very hi-spec device at a very low cost.

Did you order directly from china? I got mine through Amazon marketplace from a chinese seller.

I hope that adaptor does the trick

Oh and additionally, if you have a laptop handy you could try powering the mk808 using it!

Cheers

Share
December 3, 2012
12:30 pm
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

Thank so much for your responses
I really want to get this to work as said it seems like a great piece of kit and something I have been wanting for years
I will try to power it via the TV
Unfortunately its only my smaller bedroom TV that has a USB port but I will test it

I ordered it from amazon but it was shipped from within Europe
Still no word from the seller will reemail him tomorrow and give him to Friday before filing a claim
@mk007 did you flash it

EDIT: tried powering it through TV no luck at all
I wait for the new power source but feel I will have to flash it

Share
December 3, 2012
5:00 pm
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

some good news
I connect it via my laptop and it seems to work :)
Havent tested anything yet but hopefully its OK

So i think it maybe a power supply problem and wont need flashing

I have ordered a new power supply and it should get here by Thursday
so fingers crossed I will up and running by then

BTW the reason I bought it is to watch TV and videos online
I know there is some issues with Netflix but over all do you find that most TV/video apps are compatible with it

Share
December 4, 2012
2:58 am
audiobore

Member
Forum Posts: 35
Member Since:
November 21, 2012
Offline

Ah, great news about the ps. Simple fix!

I have really only been up and running since Friday when I bought the PS. It will take a fair bit of customising and jellybean takes a bit of familiarising but youtube HD output is excellent. I had to mess around with BBC iPlayer to configure it. It had a tiny viewing window but I got it to full screen using Settings>Advanced>UAString>Froyo-N1. The video on iPlayer is not perfect but it is synced with audio. I have not tried netflix or lovefilm instant so not sure. There is a ton of stuff on the forums so I am sure there will be a lot more to wring out of the streaming thing.

As a media player playback is perfect. MKV files are great but I suppose they should be as they are huge. My only issue is that when i connect my external hdd (via a powered usb hub) i lost the wireless keyboard connection. The only way I have so far of running files is to bung them onto a micro SD card and pop it in the slot. Not a major hardship but it would be great to have a permanently connected HDD.

There are a load of customisation topics on the forums and if you check out this video it gives you an indication of how good xbmc can look when used here.

feature=g-all

Despite the unit failing to run out of the box I am having fun messing with the options. I think you have to be prepared for a bit of that but I think you will enjoy what the mk808 does. Who knows how much more it will be able to do than anything I will ever use it for.

Have fun!

Cheers, the bore of all things 'audio'

Share
December 4, 2012
7:07 am
daz3

Member
Forum Posts: 4
Member Since:
October 24, 2012
Offline

I have the exact same problem,have tried changing all kinds of adaptors including an ipad and iphone adaptors but it just wont boot up.after the initial android logo,mine just turns blank.

Have tried to do a firmware upgrade by following max powers post but computer is unable to detect the mk808.Is my device gone?

Share
December 4, 2012
8:43 am
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

"Ah, great news about the ps. Simple fix!"
well I am not there yet. It is completely impratical and pointless to power it via my laptop
I might as well just link my laptop to my TV but I am confident it will work at the moment

@daz3 are you connecting it to your pc via the OTG connector?

Share
December 4, 2012
11:10 am
audiobore

Member
Forum Posts: 35
Member Since:
November 21, 2012
Offline

No I wouldn't suggest a laptop as a power supply, just that the right supply will get you running. Good luck

Share
December 4, 2012
1:55 pm
NO_MAD

Member
Forum Posts: 5
Member Since:
November 29, 2012
Offline

Ah, great news about the ps. Simple fix! I have really only been up and running since Friday when I bought the PS. It will take a fair bit of customising and jellybean takes a bit of familiarising but youtube HD output is excellent. I had to mess around with BBC iPlayer to configure it. It had a tiny viewing window but I got it to full screen using Settings>Advanced>UAString>Froyo-N1. The video on iPlayer is not perfect but it is synced with audio.

Hi Audiobore
I am having the same probleam with BBC Iplayer.
But can not find Advanced>UAString>Froyo-N1. on my MK808
Can you help with more info.?

NO_MAD

Share
December 4, 2012
3:46 pm
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

ITS ALIVE!
I have got it working from a mains plug
I borrowed a mains from a friend and it working
I currently have it streaming live tv from an app ((swiss) which is the main thing I want it for

I am so happy I am already falling in love with it
Unfortunately I dont have a airmouse yet but will get one

I am so relieved it works

I am sure I will have further questions
(like any apps to control it from my android phone) but thanks to all who have replied here and helped me get this up and running

:) :) :) :D :D

Share
December 5, 2012
12:46 am
audiobore

Member
Forum Posts: 35
Member Since:
November 21, 2012
Offline

Espressox, excellent! I loaded xbmc last night which is incredibly versatile. It will take me weeks to work out how to configure it but it looks amazing. Will keep you posted how I get on. I sat watching hi-def trailers of all the latest movies till after midnight last night.

No_Mad, are you running off the stock firmware? As per above, I downloaded Finless 1.5 as an attempt to fix mine so have never used it as standard. My version of iPlayer also launches in the stock browser. Once the player is launched in the browser you should see three little dots in the top right hand corner which will allow you to access the settings so you could try from there. One thing I noticed is that last night I had to reset the settings to get it to work again as it had obviously been powered down during the day. I will try over the next couple of nights to get screen shots on here of how to access it.

Cheers, the bore.

Share
December 5, 2012
4:18 am
daz3

Member
Forum Posts: 4
Member Since:
October 24, 2012
Offline

"Ah, great news about the ps. Simple fix!"
well I am not there yet. It is completely impratical and pointless to power it via my laptop
I might as well just link my laptop to my TV but I am confident it will work at the moment

@daz3 are you connecting it to your pc via the OTG connector?

Yes i did connect through the OTG connector. I had previously followed the instructions to flash the firmware before so the drivers are already installed in the computer.But now my computer just cant seem to read the device.

Is my MK808 fried?

*Edit:Finally solved the problem after i changed another usb cable!Just flashed the new firmware and its working like a charm.Pity the wifi still not very stable.
Thanks guys!!

Share
December 6, 2012
4:03 am
audiobore

Member
Forum Posts: 35
Member Since:
November 21, 2012
Offline

Magic. Actually it would seem most of the issues regarding this are about stability and not quality which is reassuring.

Have fun.

Share
December 6, 2012
6:32 am
espressox

Member
Forum Posts: 20
Member Since:
November 30, 2012
Offline

Was giving it a serious try out last night til 3am
Streamed Big Bang Theory from the internet and watch several vids through youtube
Only limitations so far seem to be what the apps can do :)
I am So happy with this easily best electrical purchase I have ever made
Plan to watch my first film on it tonight
All I need now is a proper controller for it

Anyone reading this still hesitating and trying to decide to get one or not I say get oe
I have two TVs so plan to buy a second device soon

Share
December 10, 2012
9:26 am
leiz

Member
Forum Posts: 3
Member Since:
December 7, 2012
Offline

hello.

Just got MK808 from geekbuying.com, Worked fine first couple of "runs", then freezed 2 - 3 times, and i thought thats notihing.
Didnt have anythink to control with it, so took my crappy mouse from PC. worked fine.
It worked after freezes( sorry for my BAD english).
But the next day i put the power on,( and i had bought wireless keyboard/touchpad
Logitech Wireless Touch Keyboard K400) and it worked after 2 powerup attempts ,
everything fine i thought...and then it crashed when i was trying Netflix, i try to put it on...
and.... nothing... whatta hell!!!!????

The power light didnt even turn on.
My PC didnt recognize the MK808 at all, there was nothing going on.

I have read this forum back and forth... tried every thing (i think), but nothing.
I think its fried or burned, or how do you say it...

I think it was the power supply??? or maybe the Logitech????
i have tried to take power from TV (LG 47), and from my PC and laptop, and nothing.

any hope????? maybe different power supply???( i dont think so.... :(

Share
Forum Timezone: America/Los_Angeles

Most Users Ever Online: 56

Currently Online:
3 Guest(s)

Top Posters:

bla0000: 45

audiobore: 35

ITrepairPro: 24

Melanie: 22

ruksack: 21

espressox: 20

SuicidalChef611: 19

motorcyclemikie: 19

Eric: 18

guardzero: 16

Member Stats:

Guest Posters: 9

Members: 4685

Moderators: 2

Admins: 1

Forum Stats:

Groups: 3

Forums: 21

Topics: 462

Posts: 1484

Newest Members: redtony, benyig, camle, MeLE Keith, Geekson, Jackier, jebr25, DOS76, homenet, berndbausch

Moderators: jesjhoward: 47, norcal618: 18

Administrators: Max Powers: 172